01-19-2020, Beginners/Mac Basics SIG - Custom Folder Icons

Note: This discussion is based on MacOS, 10.14.6 (Mojave). Some illustrations may differ when
using other versions of macOS or OS X. Most illustrations are from screenshots on my iMac.

In this Mac Basics presentation, we'll discuss how to create custom icons for
folders on your Mac. Why might you want to do this? It gives you another way,
other than a folder name, to help you to quickly pick out a specific folder of
interest (and also know what's inside) among many that are displayed. For
example, this may prove helpful if you have a bunch of folders on your desktop (or
a Finder folder that has a lot of sub-folders, like perhaps your Documents folder).

Credit: I borrowed heavily from a recent presentation on macmost.com. See the
credits at the end of this presentation for the URL.)

Note: What is discussed here uses the Preview app and graphic features (emojis
and apps such as Numbers) already available on your Mac. You can also use an
Image Editor like Pixelmator to create custom icons, but that’s beyond the scope of
this presentation.

“Setting the Stage”
For clarity, I'm using a simplified Mac Desktop and have enlarged the icons.

Want to change icon size on your Mac’s Desktop for easier viewing? Click on it to
make sure it's selected. In the Finder, use View > Show View Options (keyboard
shortcut: Command (38) + J) to bring up the View Options window:
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Finder: View > Show View Options

Here I've set both the Icon Size (128 x 128) and the Text Size (16) to their
maximum settings. Also, I'm going to work with just three folders (labeled Travel,
Budget and Spreadsheets).
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The Basics
Choosing the Folder to Change its Icon

Changing the icon for a folder starts with selecting the folder in the Finder and
then choosing File > Get Info (keyboard shortcut: Command (38) + I). See the
example below:

e Select the Travel folder and do Get Info for it:

7
@ @ Travel Info

Travel Zero KB
Modified: Today, 5:36 PM

Finder: File > Get Info (Top of “Get Info” Window)
e Click on the small folder icon to select it:

'v
@ @ Travel Info

" Travel Zero KB
____\ Modified: Today, 5:36 PM

Finder: File > Get Info (Top of “"Get Info” Window)
Select the Folder Icon

e Use Edit > Copy (keyboard shortcut: Command (38) + C) to copy the folder
icon to the Clipboard.

e Use the Preview app to edit the folder icon. (It's located in the Applications
folder.)

You can also use Spotlight (keyboard shortcut: Command (38) + Space) to
open Preview. Type a few letters, and then choose the app from the Spotlight list,
should be at the top, and hit Return to open it.)

e After Preview is open, use File > New From Clipboard (keyboard shortcut:
Command (38) + N) to open the previously-copied folder icon for editing.

(See the illustration on the next page.)
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Preview: Folder Icon

Notice that Preview’s window shows all the different sizes for the icon, from
highest resolution to lowest, with the highest version at the top. You’ll want to
work with this one.

e To be sure that you're working with the highest resolution size, make sure that
it's selected at the top of the left pane. Then Copy it.

e Then Close Preview’s window with File > Close Window (keyboard shortcut:
Command (38) + W) to discard it without saving. It’s no longer needed.

When the Save As dialog box is displayed, click the Delete button.
(See the illustration on the next page.)
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Do you want to keep this new document
i “Untitled”?
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Preview: Save As Dialog Box (Choose Delete)

e After Preview is open, use File > New From Clipboard (keyboard shortcut:

Command (38) + N) to open the previously-copied folder icon for editing.
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Preview: High-Resolution Folder Icon (Ready for Editing)
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Editing the Folder Icon
Change the Color

Click on Preview’s Markup Tool. After the Markup Toolbar is displayed, click the
Prism Tool (looks like a pyramid).

ooe Untitled
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Preview — Markup Tool & Markup Toolbar (Prism Tool Highlighted)
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Preview - Prism Tool Icon

Clicking the Prism Tool brings up the Prism Tool window and all its color-adjusting
options:
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Adjust Color - Untitled

Auto Levels
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Sepia:

Sharpness:

Preview - Prism Tool Controls
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As you can see, there are a lot of controls for adjusting the color of an image
being edited. Feel free to experiment with them. I recommend trying those of
interest one at a time. That way, you can always choose Edit > Undo (keyboard
shortcut: Command (38) + Z) to get back to the original color of the image.

Starting out, it might be best to stick with a simple change or two.

e Tint - By moving the slider, you can make the image more purple or green.
e Sepia - Moving the slider changes to go a tan/yellowish view.

Add a Label/Graphic

Now that you have the color you want to use, you can include some sort of graphic
on the folder icon. This can add some additional visual feature to help identify the
folder’s function and contents.

Here are three examples:

1. Add a Text Label Using Preview’s Tools. Working again with Preview’s
Markup Tool, you have a number of options/tools (Draw, Shapes, Text and Text
Style to name a few) for adding something to the folder icon.
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Preview - Markup Tool & Markup Toolbar (Line, Shape & Text Tools Highlighted)

Let’s add a simple Text Label on the folder. Click the Text Tool. A text label is
added to the image. Initially, it will probably be quite small, so use the Text Style
tool to choose the Font and Font Size. Here I've chosen the Verdana font and
increased the font size to 250 points to make the label stand out on the folder icon:
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Preview - Text Style Markup Tool
(The result, a label called Travel, is shown in the illustration on the next page.)
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Travel

Text Label Added to the Folder Icon

2. Add an Emoji Graphic. Preview’s tools are capable but somewhat limited when
adding graphics. A better option might be to use an Emoji. Emoji’s are used like text.

First, use Preview’s Text Tool to add a Text box. Next, bring up the Emoji Viewer
with the keyboard shortcut Control () + Command (38) + Space. Then you
can choose an appropriate graphic to add. In the Travel & Places group, let’s
choose one of the Airplane symbols.
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Emoji Viewer - Travel & Places Group (Airplane Symbol Selected)
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Just as with adding plain text, when you first add something, it's likely to be quite
small, so you’ll need to increase its size. In the illustration below, I changed the
size to 400 points:

Emoji Added to the Folder Icon

Note: If you want to Save a custom icon file for later use, do File > Save
(keyboard shortcut: Command (38) + S). In the Save As dialog box, selecting
png is a good format. Make sure you have Alpha selected so it's semi-transparent
for pasting appearance.

Format: [ PNG
Alpha

Save As - PNG Format & Alpha Selected

3. Add a Graphic From Numbers. The Numbers app has a humber of graphics
that you can use. The same ones are found in the Pages and Keynote apps. Let’s
work with the Budget folder.

As before:

e Click on the Budget folder to select it, do File > Get Info, and then click on
the folder icon in the Get Info window to select it. Do Edit > Copy to copy the
folder icon to the Clipboard.

e Open the Preview app and do File > New From Clipboard to open the folder
icon, select the top image (highest resolution) in the list, and do Edit > Copy
to copy the folder icon to the Clipboard. Now you can close the window and
delete the file as it’s no longer needed.

e Using the Preview app, do File > New From Clipboard to open the saved
folder icon for editing.
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Open the Numbers app and a blank document. Then select the Shape icon in the
toolbar. Notice that there are a great number of categories and shapes to choose
from. These are basic, simple shapes, not the more detailed ones found in Emojis.

Since I'm working with the Budgets folder, lets look for a suitable icon. How about
a Calculator? Rather than search through all the symbols, it's easier to search by
keyword. You only need to type a few letters to display possible choices:
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Preview App — Select Symbols Icon & Choose Calculator Icon

e Click on the Calculator icon in the Shapes list, and it’s inserted into the
Numbers document.

Calculator Icon
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e Then click on the Calculator icon in the document and then choose
Edit > Copy (keyboard shortcut: Command (38) + C) to copy it to the
Clipboard.

e Go ahead and Quit the Numbers app. We've got the Calculator icon.

e Switch back to Preview, and use Edit > Paste (keyboard shortcut: Command
(38) + V) to paste the Calculator icon onto the folder image.

Note: You don’t need to add a text box to paste the graphic.

e Since the icon’s size may be too small, drag on one of its Corner Handles to
enlarge it. Drag the graphic to position it as desired.

Preview — Paste Calculator Icon & Enlarge by Dragging a Corner

Here’s the result:

Graphic Added to the Folder Icon
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Add an Existing Icon to Represent the Folder. You can use an Existing Icon
to represent a folder. This might be useful if the folder is filled with documents of
the same type or created by the same app.

e Choose your source (maybe the Pages app) for the icon. Then using
File > Get Info select and copy its icon to the Clipboard.

e Choose your target folder (Spreadsheets) icon, and chose File > Get Info.
e In the Get Info window, click on the folder icon to select it.

e Paste the source icon from the Clipboard using File > Paste.

Here’s the result:

Spreadsheets

Pages Icon Replacing the Folder Icon

Note: Take care in selecting your source icon. Some may not stand out well
against your Desktop background.

One Problem?

There’s one problem to be aware about: From what I've read, but haven't
confirmed, you may not be able to change a folder to which you’ve added a
custom icon with another custom folder icon. This appears to be a bug in macOS
including Catalina and earlier versions of macOS. It may be addressed in a future
update.

If this is the case, you can delete the custom folder icon by selecting the folder’s
icon in the Finder, and hitting Delete to change it back to a plain folder.

An interim solution would be to create a new folder, customize its icon, and then
move your files from the old folder to the new one.

Summary

Changing a folder to a custom icon can help you to quickly pick out a specific
folder of interest if you're dealing with one among many. It can also add an
interesting effect to plain folder icons.
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Unless you want to use a custom graphics utility, the Preview app has the
capability to make simple changes. Just copy the icon from your chosen plain
folder to Preview, and edit it by adding a text label or custom icon from another
source (such as an Emoji or shapes from another app like Pages). Then copy it and
paste it to replace the old folder’s icon.

Next Presentation
For the next presentation, we’ll take a look another macOS feature.

Have a favorite Mac Tip or utility? Please feel free to pass it along, and I'll see if I
can work it into a future presentation.

If you have any suggestions for presentation topics, including macQOS utilities,
please contact me at slp4668@gmail.com.

-Sleve Parker

Credits:
https://macmost.com/how-to-create-custom-folder-and-drive-icons-for-your-mac.html
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