April 23, 2017, Beginners SIG
The Dock (Part 2 of 3)

• Note: This discussion is based on MacOS, 10.12.4 (Sierra). Some illustrations may differ when using other versions of macOS or OS X.

• Credit: http://tidbits.com/e/17088 (“macOS Hidden Treasures: Dominate the Dock,” 06 Mar 2017)¹

TidBITS is a great site for Mac information and tutorials.

Last month, I began a review of the Dock, that ribbon of icons found along the bottom of your Mac’s screen (or vertically along either side, depending on how you set it up) that contains icons representing apps and documents that you choose to place there and use.

Note: Icons in the Dock are aliases (shortcuts) for the apps and documents that they represent, not the actual items themselves. Click on an icon to open the item.

Because there’s a lot of material to cover, I decided to break my review into three parts instead of two. This month (Part 2), I’ll discuss Documents in the Dock, Minimized Windows in the Dock, and working with Folders in the Dock. Next month, I’ll finish in Part 3 by discussing working with Trash in the Dock, and Customizing the Dock’s Look and Feel.

Note: Dock actions depend on how it’s configured, the version of macOS being used and some third-party utilities. Your experience may differ (Cocktail, TinkerTool, ...).

Documents in the Dock

In addition to apps, discussed last month, the Dock can also hold documents and minimized windows. It can also hold folders (discussed later).

Add a Document to the Dock. Drag a document to the right side of the Dock, to the right of the fine vertical line divider. (See the illustration below.) Dragging the document icon creates an alias for the it in the Dock. If your Dock is located on either side of the display (vertical orientation, discussed in Part 3 next month), drop the document at the bottom, below the divider.

Adding a Document (PDF File) to the Dock by Dragging it to the Right of the Vertical Dividing Line

Notice that when you drag a document’s icon into the Dock, the adjacent icons move apart to make room for it. This action is the same for any type of icon dragged into the Dock.

Open a Document in the Dock. Click a document icon in the Dock to open it. The document will be opened by the app that was previously designated to open it. In the example above, the PDF document will be opened by Adobe Reader.

Note: As with apps, Right-Clicking or Control-Clicking on a document’s Dock icon will display a pop-up contextual menu from which you can select commands (discussed next), although the number of commands is limited.

¹ TidBITS articles may be reprinted by non-profit, non-commercial publications if full credit is given, and my article draws heavily from the article credited above.
You can choose Open “document name” from the pop-up contextual menu to open a document:

Open a Document From the Dock by Selecting “Open” From its Pop-up Menu

Remove a Document From the Dock. Select Options > Remove from Dock from the pop-up menu:

Remove a Document From the Dock by Selecting “Remove from Dock” From its Pop-up Menu

As with apps, you can also remove a document from the Dock by dragging it out until you see the Remove label appear:

Remove a Document From the Dock by Dragging it’s Icon Out of the Dock Until You See the “Remove” Label

Open a Document at Login. If you want to have a document automatically open when you login to your Mac, choose Options > Open at Login from the pop-up contextual menu:

Set a Document to Open When You Login to Your Mac by Selecting “Open at Login” From its Pop-up Menu
Show a Document in the Finder. This may be the most useful of the pop-up menu commands. Looking for apps is generally straightforward since they’re usually found in the Applications folder. However, finding a document can be illusive because you may have created many folders to hold them (and, thus, to search through). As a result, documents can be more difficult to locate.

Choose **Options > Show in Finder** from the pop-up contextual menu:

A new Finder window will be opened, and the document will be highlighted:

**“Show in Finder” Result**

Add a Web Shortcut to the Dock. In Safari (also Google Chrome or Firefox), click in the URL bar to reveal the URL (Uniform Resource Locator, the address of a webpage). To add a bookmark for a webpage to the Dock, click and drag its favicon, the small icon found at the left of the URL bar, down to the document section of the Dock. (See the illustrations below.)

Note: A favicon, short for “favorite icon” (Wikipedia: also known as a shortcut icon, website icon, tab icon, URL icon, or bookmark icon) is an icon representing a file that contains URL information associated with a particular website or Web page. Many webpages have unique favicons; some are generic.
Minimized Windows in the Dock

Virtually any type of window (folder, app, document, webpage, etc.) can be minimized (that is, moved to a Dock icon).

Minimize a Window. Minimizing a window was mentioned in Part 1 (Apps and the Dock). Clicking the window’s yellow Minimize icon (or choosing Minimize Window from Window menu of the app for the document or using the keyboard shortcut, Command-M) shrinks the window into the right side of the Dock, the same section of the Dock as for documents. (See the illustrations below.) Click a minimized window to expand it again.

Click a Window’s Yellow “Minimize” Button
Button to Minimize Its Window to a Dock Icon

Select “Minimize” from an App’s Window Menu

Minimized Safari Window in the Dock (Note the Safari Badge on the Icon)

There’s also an option to minimize a window by double-clicking on its menu bar, but this depends on a Dock preference setting which will be discussed in Part 3 next month.

Note: Minimized windows look just like thumbnails of their windows with the addition of the document’s app icon as a small badge. It’s the presence of the badge that differentiates a minimized window from a document icon or a folder icon. Depending on the size of the icons in the Dock, the badge can be a bit difficult to distinguish, so you may need to look closely.

The contextual pop-up menu doesn’t offer any options for minimized windows other than opening them (not particularly since simply clicking on the minimized icon opens it):

Remove a Minimized Window. The TidBITS article comments that “opening a minimized window is the only way to remove it from the Dock for good.” I found that dragging its icon out of the Dock will also remove it like it does for apps (one of those “your experience may vary” situations). As noted above, there’s no pop-up menu option to remove a minimized window either.
Folders in the Dock

Just as with documents, you can drag and drop folders to the Dock for quick access.

Add a Folder to the Dock. Like documents, folders must be dragged to the right of the fine vertical divider line with the Dock at the bottom of your screen (or to the bottom below the divider line if the Dock is on the left or right side of your screen). You can’t drag a folder to the left of the divider line; it will refuse to do so.

After dragging is finished, a small blue folder icon (same as used in Finder windows) is displayed:

![Folder Being Dragged Into the Dock](image)

Folder Display in the Dock. The Dock icon displayed for a folder has several subtle variations depending on the contents of the folder that was dragged to the Dock and also the “Display as” setting in the folder’s contextual pop-up menu (discussed later). See the illustrations below (“Display as” setting is set for Stack instead of Folder):

- **Folder Dock Icon (Only Documents Inside)**
  - Icon Shows Stack of Documents (No Folder)

- **Folder Dock Icon (Folder Contains One Folder and Several Documents)**
  - Icon Shows One Folder With Stack of Documents

- **Folder Dock Icon (Folder Contains Two Folders And Several Documents)**
  - Icon Shows Two Folders With One Document

- **Folder Dock Icon (Folder Contains Three or More Folders, With or Without Documents)**
  - Icon Shows a Stack of Three Folders

Note: It appears that with the Stack setting, the Dock icons can show up to three items (documents, folders and documents, or only folders) but no more.

If the “Display as” setting (discussed later) is set to Folder, only single folder icon is displayed.

Preview of a Docked Folder’s Contents. Clicking a folder in the Dock displays a pop-up preview window of the folder’s contents. So will a Click and Hold action. (See the illustration on the next page which shows one of the four preview viewing modes, Grid.)

If there are too many icons to display in the preview pop-up, a scroll bar will be available to see the rest of them. The other view modes are determined by the “View contents as” setting in the contextual pop-up menu (discussed later).
Preview of the Application Folder in the Dock (Grid View)

Also, notice that the folder’s Dock icon changes to a square with a downward-pointing arrow. Clicking this icon closes the folder preview as does clicking the Escape (Esc) key.

Open a Folder. This preview window (Grid view) also contains an icon labeled “Open in Finder” at the bottom. (See the illustration below.) As the name implies, clicking this icon will open a Finder window for the folder.

Preview of the Application Folder in the Dock

You can also select the Open command from the contextual pop-up menu for the folder (discussed below) to open it in the Finder.
Drag Items Into a Dock Folder. A Dock folder acts just like a Finder window when dragging items into it.

Simply drag a Finder item, such as a document, into a Dock folder to move it into that folder. When the folder highlights, release the mouse button to place the item in the folder:

Drag Items Out of the Dock Folder Preview Window. An Item can be dragged out of a Dock folder’s *preview window*. However, what happens with this action depends on what’s being dragged. If it’s a *document*, the item is *moved* to the new location.

However, if it’s an *application*, an *alias* of the item is created instead and moved to the target location (see below). That was my experience. Again, yours might be different.

Here I dragged the icon for the Chess app out of the preview window for the Applications folder and moved it to the Desktop.

Notice that the icon is marked with the typical *curved arrow* denoting that the icon is an *alias* for the original file (in this case, the Chess app).

Dock Contextual Pop-up Menu Options (for Documents, Minimized Windows and Folders). The Dock’s contextual menu for folders offers several options that let you customize how folders display in the Dock. Show this pop-up menu with a *Right-Click* (*Control-Click*) on the folder’s icon. (See the illustration on the next page.)

The pop-up menu is divided into several sections to group similar command options together. (See the illustration on the next page.)
Contextual Pop-up Menu for the Applications Folder in the Dock

There are several groups of options available in the pop-up menu:

**Sort By.** You can set how the Dock preview sorts documents in the folder’s preview view: by Name, Date Added, Date Modified, Date Created, or Kind (but no tags):

"Sort by" Options in Contextual Pop-up Menu

**Display As.** Two options are available for the display of a folder in the Dock: Display as Folder and Display as Stack.

"Display as" Options in Contextual Pop-up Menu

We’ve already seen the Stack option. (Refer to the previous "Folder Display in the Dock" discussion on page 5.)

With the Stack option, the icon for a Dock folder depends on its contents, and the icon may appear as multiple small folders with or without multiple document icons. With the Folder option, the icon for a Dock folder appears as a single small folder. (See the illustrations on the next page.)
The choice of displaying as a Stack or Folder is an aesthetic one. You decide whether the contents of some folders are suited to one approach or the other.

**View Contents As.** The preview display for a Dock folder has four options: **Fan**, **Grid**, **List**, and **Automatic**. (See the illustrations below and on the next two pages.) Select views as you wish to use them.

**“View content as” Display Options in Contextual Pop-up Menu**

**Fan View.** The **Fan** view is an option only when the Dock is positioned at the bottom of the screen. It shows the folder’s items in a curved stack with icon previews:
Note: The Open in Finder icon (curved arrow icon at the top of the stack in the Fan view and bottom right corner in the Grid view) is used to open the folder in a new Finder window.

If there are too many items to show in the Fan view, the label for top curved arrow icon changes to "xxx More in Finder" (see below). Clicking this icon opens the folder in a new Finder window to display the items. This display limitation is a reason why Fan view doesn’t seem very useful.

View Contents as Fan (Too Many Items to Display)
Click the “More in Finder Icon” to Open a Finder Window for the Folder

Grid View. Grid view shows preview icons for the folder’s contents in a rectangle window (as shown below). You may find it to be the most useful view. It clearly displays all the files and folders in a format that’s easy to look through. If there are too many items to show at once, you can also scroll through them to see the rest. Notice the “Open in Finder” icon in the bottom right corner.
List View. List view shows a pop-up menu of file and folder names, just like in the Finder. This view is similar to the List view for Finder windows:

![List View Window](image)

View Contents as List  List View Window

In addition to showing a list of the items in the folder, the bottom of the pop-up menu shows two more items: Options and Open in Finder:

Options – Selecting this menu item triggers pop-up sub-menu that offers the same Sort by, Display as, and View content as options previously available when Right-Clicking (Control-Clicking) in either the Fan or Grid preview options (see below).

![List View Pop-up Menu (Options Item) Displays Pop-up Sub-Menu for “Sort by,” “Display as” and “View Contents as” Options](image)

Open in Finder – Selecting this menu item will open the folder in a new Finder window.

Automatic View. The Automatic view tries to choose which display mode to use based on how many items are in the folder. It will display a preview using the Fan option only if there are just a few items in the folder. Otherwise, the Grid view is selected.
Options and Open. The last two items in the Dock’s contextual menu for folders are Options and Open “folder name”:

“Options” and “Open” Items in Contextual Pop-up Menu

Choosing Open will open the folder in a new Finder window.

Choosing Options will bring up a pop-up sub-menu with only two choices (Remove from Dock and Show in Finder):

“Remove from Dock” and “Show in Finder” Items in Contextual Pop-up Sub-Menu

Choosing Remove from Dock will remove the folder from the Dock.

Recall that you can also remove a folder from the Dock by dragging it out of the Dock until the Remove label appears above it.

Choosing Show in Finder will open the folder in a new Finder window.

One Final Dock Option. When you Command-Click a folder icon in the Dock, a new Finder window will be opened, and the folder will be highlighted showing its location:

Command-Click a Dock Folder to Highlight it’s Location in a Finder Window

Next Presentation

Next month, we’ll finish in Part 3 the review of the Dock (Working with Trash in the Dock and Customizing the Dock’s Look and Feel).

If you have any suggestions for presentation topics, please contact me at slp4668@gmail.com.

—Steve Parker